Author Topic: New to forum from Oregon-1965  (Read 154 times)

roy

  • Newbie
  • *
  • Posts: 6
    • View Profile
New to forum from Oregon-1965
« on: November 26, 2020, 11:25:06 PM »
Hello. I just joined. I have a 1965 Fintail up here in the Portland, Oregon area. My friend found the car for me this summer from the original family (I believe). 190DC. I have been going through it to make it a driver and also to teach my daughter on how to drive a clutch (4 on the tree?). Currently though it is dead in my driveway due to a broken ignition switch and I'm going through hell trying to replace it. I plan on posting for advice on this! Other than that, it runs great and put a few miles on it before the switch went kaput a few weeks ago.

Squiggle Dog

  • Moderator
  • Hero Member
  • *****
  • Posts: 514
  • IMA Universal Wagon Lover
    • View Profile
    • Fintail.org
Re: New to forum from Oregon-1965
« Reply #1 on: November 27, 2020, 01:07:51 AM »
Thanks for joining, and welcome! I really enjoyed my W110 diesel when I had it.
Stop paying for animal enslavement, cruelty, and slaughter. Save your health and the planet. Go vegan! I did 17 years ago. https://challenge22.com/

1967 W110 230 Universal Wagon Project
1980 W116 300SD Turbo Diesel 346,000

roy

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: New to forum from Oregon-1965
« Reply #2 on: November 27, 2020, 01:19:57 AM »
Thank you! It's fun. Car is a bit rough so I making my way through the mechanical and safety first. Just replaced the windshield seal. That was an experience. I had to call for professional help in the end and buy a Mercedes branded seal! Diesel engine and fuel pump were rebuilt though so it's worth my energy.