Author Topic: How to remove Becker radio from dash  (Read 138 times)

Aguila_Uno

  • Newbie
  • *
  • Posts: 10
    • View Profile
How to remove Becker radio from dash
« on: July 09, 2020, 09:49:16 AM »
Hi all,

I have a 1962 w111 220Sb. I have an original Becker Brescia radio installed which I need to remove. Does anyone know how to remove these radios out of the dash? Tried searching online but no luck. Radio is inoperative so I want to pull it out to troubleshoot it.

Thanks

Aguila
Die Mercedes Benz Heckflosse - Faszination einer Legende

Cth350

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Re: How to remove Becker radio from dash
« Reply #1 on: July 12, 2020, 10:02:57 PM »
from memory (which can be faulty), you'd be removing the knobs first, then the little metal bits that need a "escutcheon removal wrench" that unscrew from the stems of the dash knobs.

-CTH

Aguila_Uno

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: How to remove Becker radio from dash
« Reply #2 on: July 17, 2020, 11:43:43 AM »
Thanks a lot. I will give that a try
Die Mercedes Benz Heckflosse - Faszination einer Legende

Scoot

  • Jr. Member
  • **
  • Posts: 95
    • View Profile
Re: How to remove Becker radio from dash
« Reply #3 on: July 20, 2020, 04:23:05 PM »
Please post pic of Becker "Brescia".  Never heard of that flavor before...
1965 300SE Lang
1959 Borgward Isabella Coupé

Aguila_Uno

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: How to remove Becker radio from dash
« Reply #4 on: July 28, 2020, 11:44:38 AM »
I attached a picture of my Becker Brescia below. It has an automatic signal search tuning "Wonderbar". It is connected to a power/amplifier unit which is located on the passenger side and it also has a Reims unit which is a short wave adapter. I believe these were installed on the cars from Europe, parts of Asia and North Africa (I have a Euro car). More info here: http://www.mbzponton.org/valueadded/other/radios.htm. I was able to follow the wiring and found 2 other fuses in a separate fuse box under the hood. I changed out the fuses and now the Hirschmann antenna works and I can hear the power/amplifier unit turn on. Radio still doesn't work unfortunately. I did see a blue cable hanging loose in the passenger side footwell right by where all the connections are to the power/amplifier unit. It is coming from the antenna but I have no clue where to hook it up. Has anyone dealt with this before?
Die Mercedes Benz Heckflosse - Faszination einer Legende